Start a new topic

Realtime Behaviour Detection Service


Anybode else noticing that this service has started to consume more than 90% of the available CPU power?

So far, their support has been unable to assist and resolve the issue and I have tried but cannot end the task, nor can I find an option to disable this from within the software console.

How can this be stopped?



(9.68 KB)

3 people have this question

There needs to be a way to stop the behaviour detection process atleast temporarily . It's been blocking VirtualBox for me for the last two days and all my work is stuck . I hate this . Adding it to the exception list does not change anything .

I am also facing this same problem. When the service starts there is no way to stop because your cpu is 90% engaged and so it doesnt allow you to do anything. Can't find any literature on this either. When will this be resolved ? The only way I have been able escape is by force shutdown or worse hard reset.

I tried something and that fixed my problem.

I went to "Services" and changed its Startup type to MANUALĀ and rebooted my PC.

Now once reboot is done. My Quick Heal prompted me as system is not secure as its Total Ransomware Protection was disabled. (Since process didn't start as startup was manual)

I enabled it, now the the process is running but not consuming any CPU.

I hope this help you guys as well.


Instead of doing all this in my previous comment, just open quick heal.

Now disable Total Ransomware Protection.

Now check if the process has stopped.

And re-enable it.

This should solve the problem.

I also got same issue.. it's happening once in while.. not allowing to do any other tasks. Not sure what kind of support Quick heal is providing. If i restart the PC it goes back to normal.

(48.7 KB)
Login or Signup to post a comment